Resolved
This incident has been resolved. The Brizz Dashboard is operating normally. We apologize for the disruption.
Monitoring
A fix has been applied and dashboard response times have returned to normal. We are monitoring the results until full stabilization is confirmed.
Identified
Our engineering team has identified the root cause of the incident. We are currently working on a fix and planning the remediation steps to restore full service functionality.
Data ingestion and API access remain unaffected.
We will provide an update within 30 minutes.
Investigating
We are currently investigating elevated request timeouts affecting the Brizz Dashboard (platform.brizz.dev). Some users may experience slow page loads or requests that fail to complete.
Data ingestion, analytics and API access are not affected.
We will provide an update within 30 minutes.